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Chapter - 1: Overview
This guide serves as a concise introduction to the Achronix tool flow. After an overview of the tool and IP flow, 
the Quickstart design included with all ACE installations is used to illustrate the tool flow.

The Achronix design flow uses two software tools:

Synplify Pro – used for design synthesis

ACE – used for place-and-route of the design elements and for bitstream generation

Synplify Pro operates in GUI and batch modes and ACE operates in GUI, command-line, and batch modes.

Note

This user guide assumes that Synplify Pro and ACE are already installed. For help installing the tools or 
if issues are being encountered, such as problems with launching the tools or the desired device is 
missing, see the .  (UG002)ACE Installation and Licensing Guide

The following documents provide additional information on topics covered in this guide:

 (UG018)Synthesis User Guide

 (UG070)ACE User Guide

The following document provides useful information on topics not covered in this guide:

 (UG072)Simulation User Guide

http://www.achronix.com
https://www.achronix.com/documentation/ace-installation-and-licensing-guide-ug002
https://www.achronix.com/documentation/synthesis-user-guide-ug018
https://www.achronix.com/documentation/ace-user-guide-ug070
https://www.achronix.com/documentation/simulation-user-guide-ug072
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Chapter - 2: Achronix Tool Flow

Tool Flow
The Achronix design flow uses two tools:

Synplify Pro – used for design synthesis

ACE – used for place-and-route of design elements and for bitstream generation

The primary output of Synplify Pro is the design netlist which is imported into ACE for place-and-route. ACE also 
performs IP configuration, floorplanning, timing analysis, and more.

Figure 1: Achronix Design Flow

http://www.achronix.com
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IP Flow
Achronix offers two types of IP:

Core IP – traditionally thought of as "soft IP". In Achronix terminology, "core" is short for "fabric core" and 
is synonymous with what is traditionally thought of as "configurable fabric". It follows that these are IP 
cores located in the fabric of the device.

IORing subsystems – traditionally thought of as "hard IP". These interface subsystems surround the core 
and include GPIO, PLLs, memory interfaces, and more. Hence the term, "IORing".

The natural question is, "How does IP fit into the tool flow?" The answer depends on which type of IP is being 
used, though both processes begin in ACE. If using Core IP, the synthesis run must include the output products 
of the IP generation. Namely, the Core IP HDL and constraints (if any are generated). IORing subsystems do not 
need to be synthesized in Synplify Pro because ACE contains the boundary timing information between the 
IORing and Core. However, constraints from IORing subsystems are often useful in synthesis as they define 
things that would otherwise be needed (e.g., clocks are defined as part of the PLL configuration process).

See the image below for IORing subsystem and Core IP flows:

http://www.achronix.com
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Figure 2: IP Flow

http://www.achronix.com
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Chapter - 3: Launching Synplify Pro
Synplify Pro can be run in either the GUI or batch mode. Refer to the  ACE Installation and Licensing Guide

 for details on installing Synplify Pro and  for more details on synthesis.(UG002)   (UG018)Synthesis User Guide

Note

To list the several options available when launching Synplify Pro, use the  argument with the -h
 command.synplify_pro

GUI Mode
If a Synplify Pro shortcut or alias was not created, see the following table for the path to the program file.

Table 1: Synplify Pro File Paths

Executable File Typical Windows Path Typical Linux Path

synplify_pro C:\Synopsys\<version>\bin <install_path>/fpga/<version>/bin

When executed, the following window is displayed:

Figure 3: Synplify Pro Opening Display

http://www.achronix.com
https://www.achronix.com/documentation/ace-installation-and-licensing-guide-ug002
https://www.achronix.com/documentation/ace-installation-and-licensing-guide-ug002
https://www.achronix.com/documentation/synthesis-user-guide-ug018
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Batch Mode
To run Synplify Pro in batch mode, use the  argument with the  command. Reference -batch synplify_pro
designs support batch mode and have specific scripts for batch runs.

Note

A floating license is required in order to use batch mode with Synplify Pro.

http://www.achronix.com
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1.  

2.  

3.  

Chapter - 4: ACE Execution Modes
ACE can be run with full functionality in three different modes:

GUI Mode

Command-line Mode

Batch Mode

For details beyond that covered in this guide, refer to the .  (UG070)ACE User Guide

GUI Mode
If an ACE shortcut or alias doesn't exist, see the following table for the path to the executable program file.

Table 2: ACE Program File Path

Executable File Typical Windows Path Typical Linux Path

ace C:\Program Files\Achronix CAD Environment\Achronix <install_path>/Achronix-linux

To run in GUI mode, invoke the executable either with no options or with the option. GUI mode  ace  -gui
launches the interactive window from which all commands are issued.

Starting ACE in GUI Mode, Implicit

% ./ace

or

Starting ACE in GUI Mode, Explicit

% ./ace -gui

http://www.achronix.com
https://www.achronix.com/documentation/ace-user-guide-ug070
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Command-line Mode
To run in command-line mode, invoke the  executable with the  option from a console. Command-line ace -b
mode takes control of the console and allows interactive entry of Tcl commands at the command prompt.

Starting ACE in Command-line Mode

% ./ace -b

-- ACE -- Achronix CAD Environment -- Version 5.4 -- Build  84486- -- Date 2015-02-11 19:58
-- (c) Copyright 2006-2015 Achronix Semiconductor Corp.  All rights reserved.

-- all messages logged in file /home/username/.achronix/ace_2015_02_13_11_00_11.log, created at 11

:00:11 on 02/13/2015

INFO: License ace-v1.0 on server acxlicense (9 of 10 licenses available). Running on docs.

achronix.local (x86_64).

ACE>

Batch Mode
To run in batch mode, invoke the executable with the option and the option. Reference ace -b  -script_file
designs support batch mode and have scripts to refer to as examples.

Starting ACE in Batch Mode

% ./ace -b -script_file <path_to_script_file>.tcl

http://www.achronix.com
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Chapter - 5: The Quickstart Design

Introduction
The simple Quickstart design features a 2-bit binary up-counting LED display to indicate that the board and 
FPGA are operating properly upon powerup. The Quickstart design RTL along with the device-specific netlists 
and constraints are available under the  directory.<ACE_install_dir>Achronix/examples/quickstart

The  parallels this tutorial and offers a helpful addition to   videoIntroduction to Achronix FPGA Design Tool Flow
the learning process.

While this tutorial is intended to help gain familiarity with the tool flow, some details are omitted to keep it 
concise. Relevant user guides that provide additional details on the tools can be found at the end of each 
section.

Note

Screenshots in this tutorial use the AC7t1500ES0 part with the F53A0 package and C2 speed grade. 
However, Quickstart design source files for all devices are included in ACE installations.

The Quickstart Design
Synthesizing with Synplify Pro
The Synplify Pro portion of this tutorial is summarized as follows:

Figure 4: Overview of Synplify Pro Steps

http://www.achronix.com
https://www.achronix.com/training-videos/Introduction-to-Achronix-FPGA-Design-Tool-Flow
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1.  

2.  

Follow these steps to synthesize the Quickstart design with Synplify Pro:

Launch Synplify Pro and create a new project (select  from the menu). For details on File → New Project
launching Synplify Pro, see .Launching Synplify Pro (see page 9)

Add the source files (click  at the left-side of the Synplify Pro window). If already familiar with Add File...
Synplify Pro, the  file contains the pre-generated design netlist. In this case, skip to quickstart.vma

.Running Place-and-Route in ACE (see page 18)
Table 3: Synplify Project Files

Files Typical Windows Path Typical Linux Path Purpose

<device_name>_
synplify.sv

C:\Program 
Files\Achronix CAD 
Environment\Achronix\
libraries\device_models

<install_path>/Achronix-
linux/libraries/
device_models

Makes Synplify Pro aware of the device 
information necessary to perform synthesis. 
This is NOT design-specific and is required 
for all designs.

quickstart_<device_
name>.v
and
counter.v(1) (2)

C:\Program 
Files\Achronix CAD 
Environment\Achronix\
examples\quickstart\rtl

<install_path>/Achronix-
linux/libraries/examples/
quickstart/rtl

Design RTL files.

quickstart_<device_

name>_ioring.sdc(3)

C:\Program 
Files\Achronix CAD 
Environment\Achronix\
examples\quickstart\
<device_name>

<install_path>/Achronix-
linux/libraries/examples/
quickstart/<device_name>

The .sdc file type stands for Synopsys 
Design Constraints. Typical usage is to 
constrain timing, power, and area. In this 
case, a clock is defined. If the file isn't 
shown, select  in the window Files of type
and add files using .All Files (*.*)

Table Notes

1. If using a Speedcore device, the file is named  instead.quickstart.v

2. If using the AC7t1550, also add .quickstart_AC7t1550_top.v

3. If using a Speedcore device, the file is named  instead.quickstart.sdc

Tip

Files with "ioring" in their name are generated as part of the IORing flow. In this tutorial, these 
files have already been generated in order to expedite the introduction to the tools.

Note

Synplify Pro compiles files from the top down. In practice, this means the design hierarchy 
should be inverted: the lowest level files should be at the top (this is usually the device model file, 

) and files are hierarchically organized  towards their <device_name>_synplify.sv downward
top-level file at the bottom. See the screenshot below for an example using this design.

http://www.achronix.com
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2.  

3.  

Figure 5: Source Files Added to Synplify Pro Project

Select the device and set other house-keeping items (click  at the left-side of Implementation Options...
the Synplify Pro window):

Device Tab – select the , , , and  parameters that match the Technology Part Package Speed
desired device.

Figure 6: Device Tab of Implementation Options Window

http://www.achronix.com
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3.  

Implementation Results Tab – select where synthesis products are output via the Results 
 value. Observe that if the  value is changed, the final part of the Directory Implementation Name

 path changes too. This can be a convenient way of creating multiple synthesis Results Directory
runs in the same parent directory, simply by changing the  value each time.Implementation Name

Figure 7: Implementation Options Window Results Tab

Verilog Tab – set the  to the name of the top-level module (the file type is not Top Level Module
necessary, just the name).

Set  to the libraries directory in your ACE installation path. Typically this Include Path Order:
is at  for C:\Program Files\Achronix CAD Environment\Achronix\libraries\
Windows and  for Linux. This enables <install_path>/Achronix-linux/libraries/
Synplify Pro to use the Achronix libraries.

The  option is not used for the Quickstart design. In future designs, add Compiler Directives
desired compiler directives here.

http://www.achronix.com
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3.  

4.  

Figure 8: Implementation Options Window Verilog Tab

The following tabs aren't used in this tutorial but might be useful in future designs:

Options Tab – contains options like pipelining, retiming, and continuing through synthesis errors.

Constraints Tab – offers an alternative to adding constraints instead of adding them through the 
 button.Add File...

Timing Report Tab – specify the number of reported critical paths and start/end paths. Does not 
set a limit on the number of critical paths or start/end paths considered by the tool, only the ones 
reported.

GCC Tab – specifies how gated and generated clocks are handled.

Place and Route Tab – not used in the Achronix tool flow because place-and-route is performed in 
ACE.

Synthesize the design (click the big  button on the top-left of the window).Run

When synthesis finishes, a synthesized netlist (denoted by the .vma or .vm file-type) is generated in the Results 
 set earlier. Any errors, warnings, and informational messages can be found in the  Directory Project Status

window. If desired, the project can be saved by selecting  from the menu. SeeFile → Save As...  Synthesis User 
 for more information on Synplify Pro and synthesis. (UG018)Guide

http://www.achronix.com
https://www.achronix.com/documentation/synthesis-user-guide-ug018
https://www.achronix.com/documentation/synthesis-user-guide-ug018
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1.  

2.  

3.  

4.  

5.  

Running Place-and-Route in ACE
The ACE portion of this tutorial is summarized as follows:

Figure 9: Overview of ACE Steps

Follow these steps to process the Quickstart design in ACE:

Launch ACE and create a new project (select  from the menu). See File → Create Project... Launching 
 for details.ACE (see page 11)

Figure 10: New Project Creation Prompt

Set the  value to the desired directory in which to store the project.Project directory
Set the  value to "quickstart".Project name
If the  value is left blank, the name defaults to .Implementation name impl_1

Add the following files for ACE (select  from the menu, or click the File → Add Project Source Files...

http://www.achronix.com
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5.  Add the following files for ACE (select  from the menu, or click the File → Add Project Source Files...
circled button as shown in the image below):
Table 4: ACE Project Files

Files Typical Windows Path Typical Linux Path Purpose

quickstart.vma
or
quickstart.vm

C:\Program 
Files\Achronix CAD 
Environment\Achronix\
examples\quickstart\

<device_name>(1)

<install_path>/Achronix-
linux/libraries/examples/
quickstart/<device_name>

The netlist generated from Synplify Pro.

quickstart_<device_

name>_ioring.sdc(2)

C:\Program Files\
Achronix CAD 
Environment\Achronix\
examples\quickstart\
<device_name>

<install_path>/Achronix-
linux/libraries/examples/
quickstart/<device_name>

The .sdc file type stands for Synopsys 
Design Constraints. Typical usage is to 
constrain timing, power, and area. In this 
tutorial, a clock is defined.

quickstart_<device_

name>_ioring.pdc(3)

C:\Program Files\
Achronix CAD 
Environment\Achronix\
examples\quickstart\
<device_name>

<install_path>/Achronix-
linux/libraries/examples/
quickstart/<device_name>

The .pdc file type stands for Physical 
Design Constraints. Typical usage is to 
constrain I/O, placement, and routing. Since 
these are physical constraints, they are 
only used in the ACE tool as part of place-
and-route. In this tutorial, pins are defined 
and their placement set.

Table Notes

1. Use the path shown if already familiar with Synplify Pro. Otherwise, use the path set for .Results Directory
2. If using a Speedcore device, this file is named .quickstart.sdc

3. If using a Speedcore device, the file is named .quickstart.pdc

http://www.achronix.com
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5.  

6.  

Figure 11: ACE Add files Button

Select the  section within the  tab.Design Preparation Options

Figure 12: Design Preparation Section of Options Tab

http://www.achronix.com
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7.  

8.  

Set the , , and  values.Target Device Package Speed Grade
For ,  is the slowest,  is in the middle, and  is the fastest.Speed Grade C3 C2 C1
Flow Mode can be set to , , or . Of the three options,  results in the Evaluation Normal Strict Evaluation
fastest time to produce a placed-and-routed design but bitstream generation requires either  or Normal

. If the goal is to generate a bitstream, set  to .Strict Flow Mode Normal
Other than the settings above, this design uses the default values. There are other fields that are useful in 
future designs:

Package – the package of the device.

Core Voltage – the operating voltage of the device.

Junction Temperature – the expected junction temperature. While many factors affect timing, this 
value directly affects which timing libraries are used.

Click the play button (circled) to run the place-and-route flow which, upon completion, produces a 
bitstream. If  was set to , ACE completes place-and-route and timing analysis, but Flow Mode Evaluation
does not produce a bitstream.

Figure 13: Place-and-route Play Button

This completes the tutorial. A number of reports generated from the run are displayed such as timing, utilization, 
and pin assignments. If desired, the project can be saved by selecting  from the menu.File → Save Project As...
See  for more information on ACE.  (UG070)ACE User Guide

http://www.achronix.com
https://www.achronix.com/documentation/ace-user-guide-ug070
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Chapter - 6: FAQs

Why is my device not listed in Synplify Pro or ACE?
This is likely because the device overlay was not correctly installed. See ACE Installation and Licensing Guide 

.(UG002)

Which simulators are supported?
VCS (Synopsys), QuestaSim (Mentor), Incisive (Cadence), and Riviera (Aldec). Achronix does not distribute or 
provide these simulator tools.

I am in a perspective, but I would like to add a window from a 
different perspective. How do I do this?
Most windows can be added by selecting  from the menu. Select the desired window or Window → Show View
select  to see all windows that can be added.Other

I loaded an ACE project, but the information on its 
implementation is missing. How do I get that information?
Loading a project does not load its implementation run. After loading the project, right-click the implementation 
and select .Restore Implementation

How can I drive or observe signals when my device is running?
The Snapshot Debugger, found within ACE, can both drive and observe signals. See  Snapshot User Guide

 for more details.UG016

I am stuck and my question is not shown here. Who can I contact 
for help?
Contact Achronix at support@achronix.com

http://www.achronix.com
https://www.achronix.com/documentation/ace-installation-and-licensing-guide-ug002
https://www.achronix.com/documentation/ace-installation-and-licensing-guide-ug002
https://www.achronix.com/documentation/snapshot-user-guide-ug016
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Revision History

Version Date Description

1.0 26 Jan 2022 Initial Achronix release.
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